Welcome to Kap Lab Store

Topic "Error: Required skin part dropDown cannot be found."


2 Item(s)

per page
Hi All,

Trying to use autoComplete but I am getting the error:
Error: Required skin part dropDown cannot be found.

Does anyone had the same issue + how to fix.

Regards,
Bert
Posted : 30 August 2011 13:28
It too late, but may be this will help other developers!
On AutoComplete.as override stylesInitialized function by adding this code:

override public function stylesInitialized():void {
super.stylesInitialized();
this.setStyle("skin-class",Class(dropDown));
}

And don't forget to add style code:

@namespace autoComplete "com.odotrack.views.main.favorites.autocomplete.autoComplete.*";

autoComplete|AutoComplete
{
skin-class: ClassReference("com.odotrack.views.main.favorites.autocomplete.autoComplete.AutoCompleteSkin");
}
Posted : 18 May 2012 01:10

2 Item(s)

per page